pythonを頑張るブログ

突然pythonに目覚めました。何でもっと早くプログラムをやらなかったのか…後悔しています。適当に綴ります。

pipをアップデートしたらDEPRECATIONと表示される

ちょっと前からpip listを使うとエラーが出るようになりました。

DEPRECATION: The default format will switch to columns in the future. You can us e --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.con f under the [list] section) to disable this warning.

こんな感じで表示されます。
どうやらpip 9.0.1にアプデするとこのエラーを吐くようです。 対処方法が記載されているページも沢山あるのですが、ほとんどMac・・・
私はWin7を使っているのですがやっと解決出来たので記載しておきます。

と言っても、下記サイトを参考にさせてもらいました。
これ通りにやったら直りました。感謝感謝。
pip listするとDEPRECATION(非推奨)とか表示される【Python】

AppDataフォルダ直下にpipフォルダ作るという記事はいくつか見かけたのですが、私の環境では直りませんでした。
またwindowsではpip.confではなく、pip.iniファイルを作成するのでお気をつけを。
致命的ではないにせよ、すっごい気になってたので直ってよかった。

全然関係ないけど、pythonの勉強会みたいなの行ってみようかな。
connpassって言うサイト発見して色々見てるんだけど結構開催されてるのね。
写真みるとみんなMac使ってるんだけど、VAIO持っていったら笑われるかな・・・w
なんかそうゆうの気にしちゃう小心者。
Mac欲しいんだけど、万が一プログラミングやめちゃったら使い道ゼロ。
ちょっと投資するにはまだ早い気がして中々買えない。
まぁ気にせず行ってみようかな。